Software Updates

Incident Report for TNU Project

Resolved

The software has been upgraded. If any issues occur please notify our support team.
Posted Sep 15, 2021 - 17:04 PDT

Monitoring

Software updates are in progress on the main website. As such service may be degraded.
Posted Sep 15, 2021 - 16:54 PDT
This incident affected: Community/Main Website.