TS Services Offline
Incident Report for TNU Project
Resolved
This incident has been resolved.
Posted Mar 31, 2022 - 14:49 PDT
Identified
We are upgrading the TeamSpeak hosting offically marking its hand over to TNU and our management. We are moving in a direction to begin support of the new TS5 Beta. A note will be posted once the TS server is back online.
Posted Mar 31, 2022 - 02:31 PDT
This incident affected: TeamSpeak.