Software Updates
Incident Report for TNU Project
Resolved
All updates have been completed. If you have any issues please notify staff through normal support means.
Posted Oct 12, 2021 - 21:05 PDT
Monitoring
Minor software upgrades are occuring on the main website. Once the upgrades are complete this will be marked as resolved.
Posted Oct 12, 2021 - 21:00 PDT
This incident affected: Community/Main Website.